docker升级报错containerd.io >= 1.4.1的解决方案

今天打算升级一下好像没更新过的docker,然后就报错了 :(

1
2
3
4
5
6
上次元数据过期检查:1:34:25 前,执行于 2021年02月08日 星期一 09时42分10秒。
错误:
问题: package docker-ce-3:20.10.3-3.el7.x86_64 requires containerd.io >= 1.4.1, but none of the providers can be installed
- cannot install the best update candidate for package docker-ce-3:19.03.14-3.el7.x86_64
- package containerd.io-1.4.3-3.1.el7.x86_64 is filtered out by modular filtering
(尝试添加 '--skip-broken' 来跳过无法安装的软件包 或 '--nobest' 来不只使用最佳选择的软件包)

解决方案:

  1. 添加docker-ce的阿里云镜像仓库

    1
    sudo yum-config-manager --add-repo https://mirrors.aliyun.com/docker-ce/linux/centos/docker-ce.repo
  2. 升级containerd.io

    1
    sudo yum update containerd.io
  3. 升级docker-ce

    1
    sudo yum update docker-ce

大功告成~

Docker
gRPC与REST的区别
© 2020 东南dnf